Kategorien
Allgemeines

TerraTec auf Windows 7 (64-bit)

Es könnte alles so einfach sein…

Mit großer Vorfreude habe ich mich an die Arbeit gemacht, einen 3 Jahre alten DVB-T-Stick „Cinergy DT USB XS Diversity“ an meinen neu aufgesetzten Windows 7 Rechner anzuschließen. Da es auf der Herstellerseite sowohl die Software als auch den Treiber für mein Produkt gab, sollte ja eigentlich alles in Ordnung sein. Der Treiber hieß: „Cinergy DT USB XS Diversity – BDA Treiber Setup (32/64 Bit) – BDA Treiber für Windows XP (SP 2 & 3) / Windows Vista (SP 1 & 2) / Windows 7„.

…ist es aber nicht

Die Realität sah jedoch anders aus. Nach der Installation erschien ein Fensterchen, das mir bestätigte, dass der Treiber erfolgreich vorinstalliert wurde. Zum Abschließen der Installation sollte ich den Stick entfernen und wieder neu anschließen.
Ab hier passierte dann nichts mehr. So oft ich den Stick auch aus- oder einsteckte, das Fenster blieb hartnäckig stehen. Die einzige Möglichkeit, das Fenster zu schließen, war ein Abbruch der Installation. Dann fehlte aber der Treiber des Sticks und die Software war nicht betriebsbereit.

Windows-Bordmittel?

Eine Treiberaktalisierung per Windows-Update ließ auf schnellen Erfolg hoffen. Es wurde ein Treiber gefunden und der Geräte-Manager sah zufrieden damit aus. Leider hängte sich damit die Software auf und blieb ohne Rückmeldung stehen.

Gut versteckte offizielle Anleitung

Nach einiger Zeit fand ich in Foren einen Hinweis, dass es eine Anleitung des Herstellers zur Treiberinstallation gab. Diese befindet sich auf http://ftp.terratec.de/Documentation und hat den Namen BDA_Driver_Installations_Guide_Windows_7_DE.pdf.
Das Wichtigste zur Anleitung: Sie ist absolut richtig – nur leider unvollständig. Auf Seite 6 ist nämlich zu lesen, dass man den Treiber im Ordner „TerraTec“ findet, der sich im Laufwerk C befindet. Da ich mir ziemlich sicher war, dass Windows 7 nicht mit TerraTec ausgeliefert wird, war ich auch nicht sonderlich überrascht, nichts derartiges zu finden. Über die Entstehung dieses Ordners schweigt sich die Anleitung aus.

Der richtige Treiber

Wühlt man sich durch die ftp-Verzeichnisse, landet man irgendwann im Verzeichnis mit den Treibern für das eigene Produkt. Bei mir war das der Ordner http://ftp.terratec.de/Receiver/Cinergy_DT_USB_XS_Diversity/Update. Und neben den auf der Produktseite verlinkten Treibern fand ich dort noch eine weitere Datei: Cinergy_DT_USB_XS_Diversity_Drv_3.12.00.00a_XP_Vista_7.exe. Es fällt auf, dass gegenüber der oben genannten Datei das Wort „Setup“ fehlt. Beim ausführen dieser Datei passierte dann genau das, was zu erhoffen war: Es wurden Treiber entpackt und im Laufwerk C im Ordner „TerraTec“ abgelegt. Somit waren alle Voraussetzungen geschaffen, dass alle Schritte der Anleitung erfolgreich ausgeführt werden konnten.

Sender lassen sich nicht speichern

Nach erfolgreicher Treiberinstallation ließ sich auch die Software problemlos installieren und starten. Nach kurzer Sendersuche konnte ich die ersten Fernsehbilder auf Windows 7 genießen.
Die Überraschung kam nach einem Neustart. Alle eingerichteten Sender waren plötzlich wieder verschwunden. Es half auch nicht weiter, wenn ich mein Glück mehrmals versuchte.

Admin-Rechte für Administratoren

Die Lösung für dieses Problem fand ich auch erst nach längerer Suche in einem Forum: Der erste Start der Software sollte in einem Konto mit Administratorrechten durchgeführt werden. Aber nicht nur das. Der Start muss zudem mit Administratorrechten ausgeführt werden. Dazu klickt man mit der rechten Maustaste auf das Programmsymbol und klickt auf den Punkt „Als Administrator ausführen“. Das klang zwar etwas hirnrissig –  schließlich war ich ja bereits in einem Administratorkonto -, hatte aber in der Tat die gewünschten Auswirkungen. Danach konnte ich die Software wie gewohnt mit eingeschränkten Benutzerrechten starten und auch die eingestellten Sender dauerhaft abspeichern.

Zusammenfassung

Hier also nochmals in Kürze die erfolgreichen Schritte:

  • Treiber von der Produktseite ignorieren
  • Richtigen Treiber suchen (http://ftp.terratec.de/Receiver/$Produktname$/Update)
  • Anleitung suchen (http://ftp.terratec.de/Documentation)
  • Treiberdatei ausführen (sollte sich wie ein Entpacker verhalten)
  • Anleitung exakt abarbeiten
  • Software installieren und einmal in Admin-Konto mit Option „Als Administrator ausführen“ starten

Warum das so nicht auf der Herstellerseite steht? – Keine Ahnung…

Vom Support erhielt ich übrigens nach einer Woche die Nachricht, dass ich den mit „MK II“ bezeichneten Treiber verwenden sollte. Zu meinem Produkt gäbe es zwei Ausfertigungen und nur ein Treiber passe zum entsprechenden Produkt. Da ich ein weiteres TerraTec-Produkt (Soundkarte) besitze, auf dem tatsächlich auf dem Produkt die Bezeichnung „MKII“ zu lesen ist, bin ich geneigt, diesen Rat als „nicht hilfreich“ zu bewerten. Auf meinem DVB-T-Stick findet sich nicht der geringste Hinweis, dass es sich um das „MKII“-Produkt handelt. Ich habe es aber zugegebenermaßen nicht ausprobiert, da der „Drops bereits gelutscht“ war.

Update 27.02.2013:

Heute wurde ich von einem schwarzen TerraTec Home Cinema-Fenster überrascht. Und das 10 Minuten vor der Übertragung des DFB-Pokal-Highlights Bayern München gegen Borussia Dortmund. Kein Bild zu sehen, kein Ton zu hören – lediglich die Programminformation war im Nebenfenster zu sehen. Alle Spontanversuche mit Software- und Treiberaktualisierung waren vergeblich. Die Lösung fand ich erst nach dem Spiel (Danke an die ARD für den Livestream): Das am Vormittag automatisch installierte Plattformupdate für Windows 7 (KB2670838) war schuld. Dieses sollte eigentlich „für verbesserte Features und Leistung“ sorgen und enthält einige Softwarekomponenten für die Videodarstellung. Nach Deinstallation dieses Updates lief wieder alles wie zuvor. Wäre schön, wenn ich TerraTec irgendwann auch mit diesem Update zum Laufen bringen würde…

Update 07.03.2013:

Kurz nach Erscheinen des Windows-Updates hat TerraTec reagiert und einen Patch veröffentlicht. Stephan war so freundlich, seine erfolgreichen Testergebnisse mit dem TerraTec-Patch hier mitzuteilen. Bei meinen soeben durchgeführten Test konnte ich das Ergebnis bestätigen. Allerdings musste ich dazu, bei meinem Benutzerkonto mit eingeschränkten Benutzerrechten, zuerst alle Decoder in den Audio Video Settings (Einstellungen) auf den LAV Audio Decoder setzen.

12 Antworten auf „TerraTec auf Windows 7 (64-bit)“

Hallo, bei mir ist leider immer noch alles schwarz.
Zunächst nahm ich an, dass der Stick kaputt sei und kaufte mir exakt den gleichen, da ich „eigentlkch“ damit zufrieden war.
Doch mit dem neuen stick hatte ich eakt das gleiche problem.
Laut Support sollte ich alles deinstallieren und dann die frisch zugemailte Software nutzen um dann den Pach noch zu installieren. Dann sollte ich im Audio/Video bereich checken, welche Kombi am besten funktionieren würde.

Fühle mich schwer überfordert! Zwichendrin hatte ich mal Ton, dann mal Ton mit einem Bild, wo stand, das kein signal empfangen werden könne und im oberen Bereich des Bildes war ein bunter Balken drüber gesetzt.
Sitze jetzt seit ca 2 Wochen dran :-(
Falls jemand von euch noch eine Idee hätte, würde ich mich freuen,
Gruß
Moni

Hallo,
kann leider nur meine persönlichen Erfahrungen weitergeben, die bei mir problemlos funktionieren. Ob die auch bei Dir passen, muss sich zeigen.
Ich bin zwischenzeitlich zurück zu dem Stand, den ich als Update 27.02.2013 beschrieben habe: Also Plattformupdate für Windows 7 (KB2670838) deinstallieren. Dann wird auch der Patch von TerraTec nicht benötigt.
Du müsstest dann aber wieder alles deinstallieren. Am besten auch die Treiber von TerraTec. Sollte der Lieferumfang Deiner Sticks die Software TerraTec Home Cinema enthalten, dann benutze diese. Nach meiner Meinung ist die wesentlich stärker, als die inzwischen angebotene Software DVBViewer.

Hoffe, das hilft Dir weiter.

Gruß, Stefan

Hallo Schdefoon,
Den schwarzen Bildschirm ohne Ton hatte ich leider ebenfalls. Teste gerade den Patch, den ich durch Dich gefunden habe. Juhuu! Ich war schon drauf und dran die Hoffnung aufzugeben…
Ich lass Dich wissen, ob es auf meinem Win 7 64Bit das Problem behebt.

Super, danke !
Hatte natürlich die gleichen Probleme und war auch schon am verzweifeln…
Jetzt funktioniert wieder alees problemlos.

Vielen, vielen Dank für die Hilfe.

Moin Moin,

die Diskusssion ist ja schon was älter, aber das Problem war bei mir grad aktuell. Ich habe auf meinem frisch aufgesetzten Win7 Pro 64bit versucht, den schon etwas betagten Cinergy DT USB XS Diversity zum Laufen zu kriegen, der auf dem alten Rechner auch zuverlässig unter Win7 Pro 64bit lief. Mit verschiedenen Treibern und verschiedenen Softwareversionen, kamen auch immer verschiedene Fehler, nur Fernsehen, das ging nie… Habe mich dann an Adminrechten (obwohl mein Konto ein Admin-Konto ist) für die EXE versucht und an den Kompatibilitätsmodi der verschiedenen Win-Versionen – alles ohne Erfolg. Später habe ich die Installation der Terratec Home Cinema-Software als Admin und im Kompatibilitätsmodus für Win Vista (ohne SP) durchgeführt, da lief die Installation das erste Mal ohne Fehler durch. Ich habe dann wieder die EXE mit Adminrechten gestartet und im Kompatibilitäsmodus für Win Vista (ohne SP), seitdem kann ich wieder ohne Probleme fernsehen und es hat nur eine Woche Nerven gekostet…

Vielleicht hilfts.

Gruß
Tobi

Deine klare Anweisung machte mir Mut zu einem x-ten Versuch, meinen alten Cinergy DT USB XS Diversity mit meinem W7prof zu „paaren“. Hab alles ausgeführt, wie beschrieben – und beim Sendersuchlauf hängt sich das Terratec Home Cinema sofort auf. Vielleicht hast Du ja noch einen Tipp für mich…?
Danke und Gottes Segen aus Chemnitz. Markus

Hallo Markus,

toll, wenn man im Internet so gegrüßt wird :-) Herzlichen Dank dafür und auch Dir wünsche ich Gottes Segen.

Bei mir trat Dein Problem dann auf, wenn ich den Treiber Cinergy_DT_USB_XS_Diversity_Drv_Setup_3.12.00.00a_XP_Vista_7.exe installiert habe. Das Problem hat sich ja dann gelöst, als ich stattdessen Cinergy_DT_USB_XS_Diversity_Drv_3.12.00.00a_XP_Vista_7.exe benutzt hatte.

Das hast Du aber möglicherweise schon versucht…?

Könnte es sein, dass Du bereits einen Versuch mit der erstgenannten Datei unternommen hattest und die Treiber noch in Deinem System sitzen. Falls ja, versuche mal die alten Treiber loszuwerden. (Sitze gerade an einem XP-Rechner und weiß leider im Moment nicht auswendig, wo man da in den Systemsteuerungen rankommt).

Wenn es aber bei mir geklappt hat, sollte es ja auch bei Dir gehen. Melde Dich einfach nochmal, ob Dich eine meiner Vermutungen weitergebracht haben.

Gruß, Stefan

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht.